Back

Subtitle Edit 3.4.1

First maintenance release for 3.4 makes SE 3.4.1 ready for download.

The change log goes like this:

  • New: Added new subtitle formats
  • New: Can now import new time codes into OCR window - thx Music Fan
  • Improved: "Fix short display times" - thx Krystian
  • Improved: Split line improvement regarding italic/dialogue - thx moob
  • Improved: Updated Chinese Traditional language file - thx BR
  • Improved: Added .avs to list of known video formats - thx Peter
  • Improved: Avid STL format detection improved
  • Improved: Allow adding words to user dictionary with a length of 1 - thx Betsy25
  • Improved: Spell check now has better suggestions for one letter words - thx Milad
  • Fixed: Fixed crash in Visual Sync when using VLC as video player
  • Fixed:Export to image based formats now uses font from ssa/ass - thx mariner
  • Fixed:Do not lock explorer when dropping files (for OCR) in SE main list view - thx Jar
  • Fixed:Fixed dialogue issue in "auto-break lines" - thx fred
  • Fixed:Framerate conversion - fix for time based subs
  • Fixed:Fixed issue regarding showing current vs original texts on previews - thx Krystian
  • Fixed:Fixed bug in break long lines - thx moob
  • Fixed:Fixed bug in export/boxing - thx mood
  • Fixed:Minor syntax coloring fix regarding 2+ lines - thx Joel
  • Fixed:Format "CSV 3" should not load format "SPRUCE STL" - thx Adrian
  • Fixed:Added info about chars/sec to Statistics - thx Krystian
  • Fixed:Remember "Auto fix names where only casing differ" - thx Betsy25
  • Fixed:SCC format multi line italics now works - thx Shawn
Enjoy :)


by nikse.dk at 14-08-08 17:04
Note: VLC 2.1.5 64-bit has a nasty crash-on-exit-bug... so you might want to keep VLC 2.1.4...

by Reef at 14-08-08 19:23
May peace be upon you and your family and may you be blessed with enough cows to feed them, Nikse.
Very good, thank you.

by DavidGDFC at 14-08-08 21:56
Hello,

A few weeks ago, before I decided to register here today, I sent an e-mail about a bug I had found in the file spa_OCRFixReplaceList.xml. I think the bug is fixed by just deleting line 716, which is repeated, but I wanted to let you in case I've made a mistake. You find this bug when you import a SUB file and want to do an OCR. I'll be glad to provide more information if necessary.

Thanks and keep up the good work!

by ozelot at 14-09-08 02:44
There is something strange when you change framerate.
If you change from for example from 23,976 to 29,97 nothing is changed. The same for 24-]26. For 24-]26,03 the lenght of the timespan is increased. It ought to decrease.
These mysteries don't appear i version 3.40.
I'm running the portable versions.

Thank you for your excellent program.


by TeDDy at 14-09-08 07:48
Where is the "NON .Net4-4,5" version?

by TeDDy at 14-09-08 08:22
@nikse,
before throwing away the windows 2000/XP users of this wonderful program:
Please, can you consider to ADD some features in the find/replace/multiple replace/wordlist corrections?
This is a very necessary feature:
- Match CaSe
- Entire word

This will be very helpful in correcting subtitles, cutting a lot of the rules I must build.
I know I probably should consider to migrate to other tools or build/use external programs to make the text corrections.
I think still think the Swiss Knife(Subtitle Edit) can gain few more "blades"

Should be simple enough to ADD the features IF YOU WANT !!!

by nikse.dk at 14-09-08 08:36
@TeDDy: .net 2 version uploaded :)
Edit -> Multiple replace is a powerful tool - try using "regular expressions" which will give you case sensitivity + entire word find/replace functionality - and much more!

by techguru at 14-09-08 10:49
is SE .net 4.5...or is it usable with 4.0..cause for anyone complaining about xp....net 4.0 works on xp just fine...need an update first tho

by techguru at 14-09-08 10:50
and if your still on win 2000..get a life!...time to upgrade!

by Translated at 14-09-08 17:29
Hi Nikolaj Olsson.

Thank you for new Version.

please A minor release for add:
1.Calculated for getting ready Subtitle(percent translated).
Thank you

The first method:
percent with subtitle orginal and new subtitle. (percent per line translated)

The second method:
percent with only new subtitle (blank) and translated per movie time.
movie 60min: Translated to 30 minutes is 50%

by johnnn at 14-10-08 03:10
fps conversion not working properly in new version 3.4.1, in 3.4.0 working fine

by SilverDrake at 14-14-08 11:41
Hi Nikolaj,
I confirm what was said by ozelot and johnnn, I always use the conversion from 23,976 to 25, and with version 3.4.1 no longer works.

And another thing: since version 3.4.0 when the next line begins with the same timing of the previous, overlay error is signaled. It's something intended or a bug? Because at least in my opinion, there is no error.

Happy Holiday ;-)

by nikse.dk at 14-14-08 13:55
I'll revert the frame rate conversion, but it kinda depends on how the original subtitle timing was loaded, via total frame numbers or via some HH:MM:SS:something timestamps. In the latter case 25fps and 30fps should be the same I think, but not in the first case.

by nikse.dk at 14-17-08 09:54
@SilverDrake: About the overlay errors, it's intended but I think you can turn it off via options - settings - syntax coloring - color time code overlap.

by moob at 14-17-08 15:41
@nikse

update pt-PT language to 3.4.1 and fix some typo

http://www3.zippyshare.com/v/25957860/file.html

;)

by Tanja at 14-17-08 19:42
Hi!
I have one question.
When I download the Zip file 3.4.1. , it only contains the Set-up file. After I extract and try to run it, it requires that I download NETframework platform.
Is this necessary?
Thanks

by nikse.dk at 14-18-08 08:28
@Tanja: Yeah, the .net framework is necessary, sorry.

by Daniel at 14-18-08 13:29
Hi!

After updating both the VLC and the SE when trying to create waveform, the only thing I get is a Pop-Up Error notification and instead of a waveform, iot "creates" a white field with a red cross. Cann anyone help?

Daniel

by Shivali at 14-19-08 02:01
Hey, thanks for the program, its great. I have an issue and is that i don't know how, perhaps with some key combination i changed the keyboard language from spanish to english and don´t know how to return it to spanish. The thing is that is only in the program, not happening in windows (word, etc.), so how can i get the spanish versión of the keys, this is very messy to write, thanks

by nikse.dk at 14-19-08 06:56
@Daniel: Perhaps you can try with FFMPEG for extracting the audio via options - settings - waveform?

@Shivali: Probably depends on your OS - in Win7 I just change language via the taskbar.



by Tronar at 14-22-08 23:37
Thanks for the update. It's appreciated. I have an issue with 3.4.1 though, that doesn't happen in the older versions.

I had already edited a file with 3.4.0 and run "Fix common errors" on it. And then I reloaded it with 3.4.1 and used the "Fix common errors" function again. To my surprise it found one line, that hadn't popped up before with the comment "fix short display time". It suggested moving the end time from 00:41:18,137 to 00:41:18,260. Which wouldn't be a problem, if the following line hadn't started at 00:41:18,142.
I let Subtitle Edit 3.4.1 run its course nonetheless and as a result the start time of said following line was moved up by the "fix short display time" function as well to 00:41:18,285!
I watched the part of the clip to see how it plays out and unfortunately as a result, this second line now started TOO LATE. The addition of so many seconds was also too much and I wonder why Subtitle Edit deemed such a strong extension of the display time necessary.

Which means for me, that the function "fix short display time" is unuseable right now. I double checked with 3.3.15 and 3.4.0 and both don't display this problem.

For the record, the setting in "settings-]tools-]fix short display time - allow move of start time" is set to off. Since I also don't like moving the starting time of a short display sub.

I am a bit puzzled, since the changelog for 3.4.1 doesn't mention any change for the "fix short display time" function. Should this be just a bug, please correct it. Should this new behavior be intended, please add another setting to revert its functionality to the 3.4.0 behavior, which worked perfectly.

Thank you very much!

by Charles at 14-23-08 01:12
HI!
SE is good program
SE can not reading sup subtitle format files.
SE 3.3.15 is Fine.
SE 3.4.1 is crash on .NET 2.0 vesion.(.NET 4.0 vesion is fine)
Also mkv muxed vodsub(idx/sub) subtitle crash on NET 2.0 version.

Thanks.

by nikse.dk at 14-23-08 15:03
@Tronar: thx for the info :)
Change log updated. It is actually a very nice improvement I think (it uses max. chars/sec to determine short display times).
"Allow move of start time" should now also be checked if moving any start times.
A more complete change log is available here.

by Tronar at 14-24-08 00:40
@Nikse.dk

Thanks for the fast response. I am not sure if I understand your post correctly though.

You are saying that this new behavior is a feature, not a bug, correct?

Some might like it, I guess. But for me it is a problem if a subtitle line starts way too early (that's why I was happy about the setting "Allow move of start time" and always had it set to OFF!)

But it is an even bigger problem, if a line starts too late.
Is there any other way for me right now to turn that new 3.4.1 behavior off, other than to omit the feature "fix short display time" in its entirety?

Which would be a shame, but for me still the lesser evil. I'd rather have slightly too short display times then wrong start times.

Or are you saying the next version 3.4.2 will have the issue fixed according to your more complete changelog?

Reading through the content behind the link again, I guess it is the latter, but I am not sure, since I am not too familiar with the way you release updates and report changes. So a quick confirmation/clarification from your side would be helpful.

Is there a release date planned for 3.4.2 yet?

Thanks again for your great work. SubtitleEdit is definitely the best tool to correct and re-sync subs.

by moob at 14-26-08 19:57
@nikse

update pt-PT language to last git

http://www60.zippyshare.com/v/3345240/file.html

;)

by nikse.dk at 14-26-08 21:27
@Tronar: Please do test latest beta version where it should possible to turn off moving of start time when fixing overlapping time codes. 3.4.2 should be out soon...

@moob: thx for the update :)

by admas at 14-27-08 09:27
Update pl-PL language file for SE to 3.4.1 build 82

http://potplayer.pl/downloads/pl-PL.zip

by nikse.dk at 14-27-08 12:12
@admas: thx for the update :)

by domddol at 14-29-08 15:11
@nikse

http://min.us/i/hTXcZFihSVna

by nikse.dk at 14-30-08 20:13
@domddol: check latest language master... also, that "EBU properties" should not always be visible (fixed now), so thx for the info.

by Singul.Arita at 14-30-08 23:10
Thank you for excellent program. Can I suggest to you a little improvement? I would be great, if I can export results of comparison (only differences). And again THANKS.

by moob at 14-31-08 01:34
@nikse

update pt-PT language to last git-1e8f280

and fix typo (Chararacters to Characters)

http://www40.zippyshare.com/v/72047338/file.html


;)

by moob at 14-31-08 02:23
@nikse

forget my previous post, I made mistakes sorry for that.

this is the correct one ;)

update pt-PT language to last git-1e8f280

and fix typo (Chararacters to Characters)

http://www57.zippyshare.com/v/42808173/file.html

;)

by domddol at 14-31-08 08:00
Updated Korean-lang for SE_3.4.1

https://drive.google.com/file/d/0B3uFlkYXpd_oa2hOelMwcGgweVk/edit?usp=sharing

by admas at 14-31-08 09:44
Update pl-PL language file for SE to 3.4.1 build 119
http://potplayer.pl/ccount/click.php?id=2

by nikse.dk at 14-31-08 11:55
Thx for the language file updates :)
Committed on GitHub

by Steve S. at 14-01-09 15:03
I love your software! However, I have noticed the last version upgrade 3.4.1 in portable format running much slower on my windows 7 64bit???

by nikse.dk at 14-01-09 18:47
@Steve S.: Doing what, compared to what version?
Could you also try latest portable beta?
What UI language do you use in SE?

by kdj at 14-02-09 14:35
Hi!
Thanks for making and maintaining this outstanding program.

I have some minor issues regarding imagebased subs (DVB-subs from recorded TV broadcast MPEG-TS).

I've been using the "OCR via Tesseract" option. Works great, except for this: The character sequense "[space]...[space]" is 'left out' by tesseract; it never appears in the resulting output text. Only happens when the punctuation marks are delimited by spaces - ie. "[space]...!" or "x...[space]" are recognized and processed correctly. Unfortunately "[space]...[space]" are used a lot in my DVB-subs, making manually correcting this a tedious buisness, to say the least.
Any chance of this beeing corrected?

As an alternative, I have used the option to export DVB-subs to bluray-sup. Basically this works well, but the options available in the 'Blu-ray SUP' windows (Alpha, Shadow width) seems to have no effect at all. A working option to adjust background transparency would be very nice. And maybe an option to apply a scaling factor to the resulting image files?

EDIT: The OCR via MODI option does'nt show up in 3.4.1 and 3.4.0. It does work up to version 3.3.15. However, if any other language than english, french or spanish are selected, it only yields empty text fields. Could be some built in limitation in MODI-OCR?

by pson at 14-03-09 22:59
Thanks again for another update :)

Got a request for a future update regardingImport/OCR VobSub dialog.

Would it be possible to have the individual subtitle images visible along side the OCR'd text? So in a column just like the ones for 'Start time', 'End time', 'Duration' and 'Text' there would be one for the image.
You then just have to use the scroll wheel on the mouse to go through the text for errors instead as for now when you have to use the arrows on the keayboard and go through them one by one wich is incredible tiresome.
You don't even have to see the actual text, just so that you see if it's italic and if it looks like this http://img107.imagevenue.com/img.php?image=66398_Capture_122_509lo.jpg since the tool doesn't recognise these kind of texts as said by two different persons and doesn't add a - before each sentence.

by pson at 14-03-09 22:59
Thanks again for another update :)

Got a request for a future update regardingImport/OCR VobSub dialog.

Would it be possible to have the individual subtitle images visible along side the OCR'd text? So in a column just like the ones for 'Start time', 'End time', 'Duration' and 'Text' there would be one for the image.
You then just have to use the scroll wheel on the mouse to go through the text for errors instead as for now when you have to use the arrows on the keayboard and go through them one by one wich is incredible tiresome.
You don't even have to see the actual text, just so that you see if it's italic and if it looks like this http://img107.imagevenue.com/img.php?image=66398_Capture_122_509lo.jpg since the tool doesn't recognise these kind of texts as said by two different persons and doesn't add a - before each sentence.

by techguru at 14-05-09 08:52
@pson..basically you want a quality checking box for the OCR....yea we been asking for that since early versions of 3.0....I don't think nikse wants to do that

best way to do this would be a subtitle overlay over the image based subs..and so we could change the font used on the subtitle so it matched up to the image based subtitles...then it would be very easy to see mistakes in the ocr'ed subtitles

by techguru at 14-05-09 08:52
@pson..basically you want a quality checking box for the OCR....yea we been asking for that since early versions of 3.0....I don't think nikse wants to do that

best way to do this would be a subtitle overlay over the image based subs..and so we could change the font used on the subtitle so it matched up to the image based subtitles...then it would be very easy to see mistakes in the ocr'ed subtitles

by George at 14-05-09 17:55
Thank you nikse. Is there a chance you could restore as an option the previous method of spell-checking with Word? I cannot find it any more. The "Microsoft Word spell & grammar checker" window does not work well with Greek (the language is not even detected).

by George at 14-05-09 17:55
Thank you nikse. Is there a chance you could restore as an option the previous method of spell-checking with Word? I cannot find it any more. The "Microsoft Word spell & grammar checker" window does not work well with Greek (the language is not even detected).

by pson at 14-05-09 22:55
@ techguru
Yes the main idea sounds the same but if I understand your suggested solution correctly it sounds a lot more advanced and complicated to program than what I'm asking for.

by pson at 14-05-09 22:55
@ techguru
Yes the main idea sounds the same but if I understand your suggested solution correctly it sounds a lot more advanced and complicated to program than what I'm asking for.

Name *
E-mail (Optional)
Comment *
Do you want to delete the comment?

Comment



Back   |   Login   |   New user